HTML5 and WebSocket Supported

Published on Tuesday, November 12, 2013

1: Web Socket Protocol Support:

 

  • IIS 7.5, IIS 7.0 and previous versions were NOT supported;

  • IIS 8.0 Support Web Socket Protocol;

  • Windows Server 2012 required because IIS 8.0 is ONLY available in Windows Server 2012 and Windows 8

  • IIS 8.0 Express can be installed in Windows 7, Windows Server 2008, Windows Server 2008 R2, but we can NOT give IIS 8.0 Express to customers; we can use IIS 8.0 Express as development environment though;

  • .NET 4.5 Frameworks required;

 

image

http://www.iis.net/learn/get-started/whats-new-in-iis-8/installing-iis-8-on-windows-server-2012

 

image http://www.iis.net/learn/get-started/whats-new-in-iis-8/iis-80-websocket-protocol-support     **2: HTML5 Support:**   - All IE versions before IE 10 do not support HTML5 or only support HTML5 small part; - IE 10 supports HTML5 but not the best; - IE 11 support HTML5 better but there is still other issues after Microsoft released recently; - Newer Chrome versions support HTML5 well; - Newer Firefox versions support HTML well;   image

http://caniuse.com/

http://fmbip.com/litmus/

http://html5test.com/results/desktop.html